Das Problem wurde mit BuddyPress 1.2.4.1 behoben.
Zurzeit wird BuddyPress 1.2.4 leider mit einem Bug ausgeliefert, der die Tabelle ‘wp_bp_user_blog’ leeren kann. Dadurch funktioniert das Blogverzeichnis nicht mehr. Ein Update wird aufgrund der Sicherheitslücken dennoch empfohlen, daher gilt vor der Aktualisierung diese Tabelle (‘wp_bp_user_blog’) zu sichern und nach abgeschlossener Aktualisierung ggf. die Tabelle wiederherzustellen.

Mit BuddyPress 1.2.4 wurde ein Bug-Fix-Release veröffentlicht, der u.a. die Kompatibilität zu WordPress 3.0 verbessert. Des Weiteren wurden einige Sicherheitslücken behoben, wie z.B. konnte man sich ohne Einladung Zugriff auf private bzw. verstecke Gruppen verschaffen. Außerdem wurde der Upload von Benutzerbildern ausgebessert. Im komplette Changelog sind alle Änderungen zu finden. Eine Aktualisierung wird dringend empfohlen.

Die deutsche Sprachdatei wird bei einer automatischen Aktualisierung leider gelöscht und muss daher manuell wieder hoch geladen werden. Einfach die Datei “buddypress-de_DE.movon dieser Seite herunterladen und in den Ordner “/wp-content/plugins/buddypress/bp-languages/” kopieren.